summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a6d60f1f920
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Christopher Hamilton <marker5a@gmail.com>
+
+pkgname=easyterm
+pkgver=0.9
+pkgrel=6
+pkgdesc='Serial Port Terminal Emulator'
+arch=('x86_64' 'i686')
+url='http://sourceforge.net/projects/easyterm/'
+
+license=('GPLv3')
+depends=('qt5')
+depends=()
+makedepends=('git')
+optdepends=()
+provides=()
+conflicts=()
+source=()
+md5sums=()
+_gitroot="http://git.code.sf.net/p/easyterm/code easyterm"
+_gitname="easyterm"
+
+build() {
+ cd ${srcdir}/
+
+ msg "Connecting to the GIT server...."
+ if [[ -d ${srcdir}/${_gitname} ]] ; then
+ cd ${_gitname}
+ git pull origin
+ msg "The local files are updated..."
+ else
+ git clone ${_gitroot}
+ fi
+
+ cd ${_gitname}
+
+
+ qmake .
+ make
+}
+
+package() {
+ cd "easyterm-code"
+
+}
+
+# vim:set ts=2 sw=2 et: