summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8427c9960ff3..3735031d3371 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,22 @@
pkgname=eclipse-pmd
pkgver=4.0.8
_buildtime=v20151003-1954
-pkgrel=1
-pkgdesc='PMD plugin for Eclipse IDE to analyze static Java, Javascript, XML, and XSL source code'
+pkgrel=2
+pkgdesc='PMD static source code analysis (Java, XML, ...) plugin for Eclipse IDE'
arch=('any')
url='http://pmd.sourceforge.net/'
-license=('BSD')
+license=('BSD' 'Apache')
depends=('eclipse>=4.5.0')
options=('!strip')
source=(
"feature.jar::http://downloads.sourceforge.net/project/pmd/pmd-eclipse/update-site-latest/features/net.sourceforge.pmd.eclipse_${pkgver}.${_buildtime}.jar"
"plugin.jar::http://downloads.sourceforge.net/project/pmd/pmd-eclipse/update-site-latest/plugins/net.sourceforge.pmd.eclipse.plugin_${pkgver}.${_buildtime}.jar"
+ "license.txt::http://sourceforge.net/p/pmd/code/ci/master/tree/LICENSE?format=raw"
)
-noextract=(feature.jar plugin.jar)
+noextract=(feature.jar plugin.jar license.txt)
sha256sums=('dadd49ecfe5832f91293b20bdb747506aa6d2330a7fbc802819c7049598e4c77'
- 'a40c8a27d0ba07619b1e0693634ec7465b1c760135b4f9807b7a8a8959f0faf0')
+ 'a40c8a27d0ba07619b1e0693634ec7465b1c760135b4f9807b7a8a8959f0faf0'
+ 'bc61ca15a6e980814d4183a0d37713179a682a8376fe4304c0d99792af62025c')
package() {
_dest=$pkgdir/usr/lib/eclipse/dropins/${pkgname/eclipse-}/eclipse
@@ -27,5 +29,5 @@ package() {
jar xf $srcdir/feature.jar || return 1
# copy plugin
install -Dm644 $srcdir/plugin.jar $_dest/plugins/net.sourceforge.pmd.eclipse.plugin_${pkgver}.${_buildtime}.jar
+ install -Dm644 $srcdir/license.txt $pkgdir/usr/share/licenses/eclipse-pmd/license.txt
}
-