summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77488e8cacde..c21230aa609c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,22 @@
# Maintainer: Eric Ozwigh <ozwigh at gmail dot com>
pkgname=eclipse-pydev
-pkgver=7.2.1
+pkgver=12.0.0
pkgrel=1
pkgdesc="Python IDE for Eclipse"
url="http://pydev.org/"
arch=('any')
license=('EPL')
-depends=('java-environment>=8' 'eclipse>=4.6')
+# after moving Eclipse to AUR (why?) there is a mess with a bunch of packages.
+# this one is for "eclipse-platform" and other packages which uses correct
+# "provides=eclipse" option.
+depends=('java-environment>=11' 'eclipse>=4.6')
+# for "eclipse-common/etc/etc" uncomment the next line.
+#depends=('java-environment>=8' 'eclipse-common>=4.6')
makedepends=('unzip')
conflicts=('eclipse-aptana')
source=("PyDev_${pkgver}.zip::http://downloads.sourceforge.net/project/pydev/pydev/PyDev%20${pkgver}/PyDev%20${pkgver}.zip")
-sha1sums=('1bddf1534fa9164184ec406b48b14bd2954ec9dd')
+sha1sums=('89659ae38b058d1987410518daece22a7fccf5f1')
package() {
_dest="${pkgdir}/usr/lib/eclipse/dropins/pydev"