summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 874186fe7a0e..8c7608f7d66d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,27 @@
# Maintainer: revel <revelΘmuub·net>
# Contributor: shild <sxp@bk.ru>
+# Contributor: m4tx <m4tx@m4tx.p>
pkgname=edb-debugger
-pkgver=0.9.21
-pkgrel=3
-pkgdesc="EDB (Evan's Debugger) is a QT4 based binary mode debugger with the goal of having usability on par with OllyDbg."
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="EDB (Evan's Debugger) is a Qt5 based binary mode debugger with the goal of having usability on par with OllyDbg."
arch=('i686' 'x86_64')
url='http://www.codef00.com/projects#debugger'
license=('GPL2')
-depends=('qt5-xmlpatterns' 'capstone>=3.0')
+depends=('qt5-xmlpatterns' 'qt5-svg' 'capstone>=3.0')
makedepends=('boost>=1.35.0' 'cmake')
optdepends=('graphviz>=2.38.0')
-install=edb.install
source=("https://github.com/eteran/edb-debugger/releases/download/$pkgver/edb-debugger-$pkgver.tgz"
'edb.desktop'
- 'plugin_path.patch'
- 'compile.patch')
-md5sums=('3754a96538b8f881153d26e4bb96e423'
- '8844cd95efef848f8f4a444259491961'
- '76f3b5f5b51301d3334a93bdf54f3819'
- 'bf3522695c8e00f1649f91ac3a64b064')
-sha256sums=('2686619e1288152033d4c9c9a2568cb12841d3854bba8815c37ce77d3bd11706'
- 'af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132'
- '7f28fd5f37bc4493a48c199074ec4393b971246e8d208c28f4348d526ac60dce'
- 'dde1df3ab4c51513ff15c6eddbc63ff6fc8dddd8a51175b2f7911a2d0c8a237a')
+ 'plugin_path.patch')
+sha256sums=('fab87541042df79ea63254e371d81b84d6b72f78141a6ab92512610ed2b7dfac'
+ 'e10b1f8ad676fe2037d62bc8600d8564772ad5e603b10a387b7375b878f60ae4'
+ '2b769b96d099036fcb606f32e52465ad6594c098d4060c9fb4d76e05d2f42cab')
prepare() {
cd "edb-debugger-$pkgver"
patch -p1 -i ../plugin_path.patch
- patch -p1 -i ../compile.patch
}
build() {