summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a68b963fb4cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+pkgname=edgar-ssh
+_upname=edgar
+pkgver=1.1
+pkgrel=1
+pkgdesc="A small utility to maintain SSH config files"
+arch=("any")
+url="https://git.umaneti.net/${_upname}/about/"
+license=("WTFPL")
+depends=("python-yaml")
+makedepends=("python-setuptools")
+source=("https://git.umaneti.net/${_upname}/snapshot/${_upname}-${pkgver}.tar.gz")
+sha256sums=('7cb686afdf9e94f586b93f54d88905331bbcdbdc929207e9b312eb362aab171a')
+
+package() {
+ cd "${_upname}-$pkgver"
+ python setup.py install --no-compile --root=$pkgdir
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${_upname}/LICENSE"
+}