summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 22 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c40f25910f0c..a7b9b29234dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,36 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=edir
-pkgver=2.7.2
+pkgver=2.7.3
pkgrel=1
pkgdesc="Program to rename and remove files and directories using your editor"
url="https://github.com/bulletmark/$pkgname"
license=("GPL3")
arch=("any")
depends=("python>=3.5")
-makedepends=("python-setuptools")
+makedepends=("python-pip" "python-wheel")
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('a77763cbe61abf838fe31c5cb87f5a9acf1a09f2')
+sha1sums=('f6123dd650aa67ffce5f1af123fe02ee5a677123')
package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$pkgname-$pkgver"
+
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --root="$pkgdir" \
+ --isolated \
+ --ignore-installed \
+ --no-deps \
+ --disable-pip-version-check \
+ --no-python-version-warning \
+ --no-warn-script-location \
+ --no-cache-dir \
+ --no-compile \
+ .
+
+ local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
+ local _pkgname=${pkgname//-/_}
+ cd "$pkgdir/$pdir"
+ rm -f $_pkgname-*.dist-info/direct_url.json
+ python -O -m compileall -q .
}
# vim:set ts=2 sw=2 et: