summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b05cf417630..37566e34c8b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=editorconfig-core-c-git
-pkgver=0.12.3.r38.ge70d90d
+pkgver=0.12.6.r4.gaa6b3ed
pkgrel=1
pkgdesc="EditorConfig core library written in C (for use by plugins supporting EditorConfig parsing)"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://github.com/editorconfig/editorconfig-core-c"
license=('BSD')
depends=('glibc' 'pcre2')
makedepends=('git' 'cmake')
-provides=('editorconfig-core-c')
+provides=("editorconfig-core-c=$pkgver")
conflicts=('editorconfig-core-c')
source=('git+https://github.com/editorconfig/editorconfig-core-c.git')
sha256sums=('SKIP')
@@ -24,14 +24,14 @@ pkgver() {
build() {
cd "editorconfig-core-c"
- mkdir -p "_build" && cd "_build"
cmake \
+ -B "_build" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DINSTALL_HTML_DOC=ON \
- "../"
- make
+ ./
+ make -C "_build"
}
package() {