summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc03b39d1503
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tom Richards <tom@tomrichards.net>
+# https://github.com/t-richards/aur-editorconfig-gedit
+pkgname=editorconfig-gedit
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="EditorConfig plugin for gedit"
+arch=('any')
+url="http://editorconfig.org"
+license=('BSD')
+depends=('gedit' 'python-editorconfig')
+
+source=("https://github.com/editorconfig/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('d6c88a400bfbab36355ab6674db65c0d4997c970fc58a08752c1b331bea625e3')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ # Plugin
+ _installdir="$pkgdir/usr/lib/gedit/plugins"
+ mkdir -p "$_installdir"
+ cp -r editorconfig_plugin/ "$_installdir"
+ cp editorconfig.plugin "$_installdir"
+ cp editorconfig_gedit3.py "$_installdir"
+ sed -i 's/python/python3/' "$_installdir/editorconfig.plugin"
+
+ # License
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+