summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 4 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99c29f470732..dc1205bb9825 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,10 @@
# Maintainer : Keshav Padram <(the.ridikulus.rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
# Contributor: Murtuza Akhtari <inxsible at gmail dot com>
+_gitroot="http://linux.dell.com/git/${_pkgname}.git"
+_gitname="${_pkgname}"
+_gitbranch="master"
+
_pkgname="efibootmgr"
pkgname="${_pkgname}-git"
@@ -16,10 +20,6 @@ conflicts=("${_pkgname}")
provides=("${_pkgname}")
options=(strip purge docs zipman !emptydirs !libtool)
-_gitroot="http://linux.dell.com/git/${_pkgname}.git"
-_gitname="${_pkgname}"
-_gitbranch="master"
-
source=("${_gitname}::git+${_gitroot}#branch=${_gitbranch}")
sha1sums=('SKIP')
@@ -28,30 +28,6 @@ pkgver() {
git describe --always | sed 's|-|.|g'
}
-_update_git() {
-
- cd "${srcdir}/"
-
- msg "Connecting to GIT server...."
-
- if [[ -d "${srcdir}/${_gitname}/" ]]; then
- cd "${srcdir}/${_gitname}/"
- git reset --hard
- git fetch
- git checkout "${_gitbranch}"
- git merge "remotes/origin/${_gitbranch}"
- msg "The local GIT repo has been updated."
- else
- git clone "${_gitroot}" "${_gitname}"
- cd "${srcdir}/${_gitname}/"
- git checkout "${_gitbranch}"
- msg "GIT checkout done or server timeout"
- fi
-
- echo
-
-}
-
build() {
rm -rf "${srcdir}/${_gitname}_build/" || true
@@ -64,7 +40,6 @@ build() {
}
-
package() {
cd "${srcdir}/${_gitname}_build/"