summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dadcdb562572..8563c963ad10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer : Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
+# Contributor : Tobias Powalowski <tpowa@archlinux.org>
_pkgname="efivar"
pkgname="${_pkgname}-git"
@@ -7,7 +8,7 @@ _gitroot="https://github.com/vathpela/efivar.git"
_gitname="${_pkgname}"
_gitbranch="master"
-pkgdesc="Library to manipulate EFI variables - GIT Version"
+pkgdesc="Tools and library to manipulate EFI variables - GIT master branch"
pkgver=0.8
pkgrel=1
@@ -18,7 +19,7 @@ makedepends=('git')
depends=('popt')
conflicts=("${_pkgname}" 'libefivar' 'libefivar-git')
provides=("${_pkgname}=${pkgver}" "libefivar=${pkgver}" "libefivar-git=${pkgver}")
-options=('!strip' 'emptydirs' 'zipman' 'libtool' 'docs' '!makeflags')
+options=('!strip' 'zipman' 'docs')
source=("${_gitname}::git+${_gitroot}#branch=${_gitbranch}")
sha1sums=('SKIP')
@@ -48,12 +49,6 @@ build() {
cd "${srcdir}/${_gitname}_build/"
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
-
make libdir="/usr/lib/" bindir="/usr/bin/" mandir="/usr/share/man/" includedir="/usr/include/" V=1 -j1
echo