summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd3dfc251e46..8b4e9b2061ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: David McInnis <davidm@eagles.ewu.edu>
-# Contributor: Tom Gundersen <teg@jklm.no>
+# $Id: PKGBUILD 204732 2014-01-26 09:43:39Z ronald $
+# Maintainer: Tom Gundersen <teg@jklm.no>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
pkgname=eigen2
pkgver=2.0.17
-pkgrel=3
-pkgdesc="C++ template library for linear algebra: matrices, vectors, numerical solvers, and related algorithms"
+pkgrel=2
+pkgdesc="A lightweight C++ template library for vector and matrix math, a.k.a. linear algebra"
arch=('any')
-url='http://eigen.tuxfamily.org'
+url='http://eigen.tuxfamily.org/index.php?title=Main_Page'
license=('GPL' 'LGPL3')
makedepends=('cmake' 'pkg-config')
source=("http://bitbucket.org/eigen/eigen/get/${pkgver}.tar.bz2")
-sha256sums=('7255e856ed367ce6e6e2d4153b0e4e753c8b8d36918bf440dd34ad56aff09960')
+sha1sums=('461546be98b964d8d5d2adb0f1c31ba0e42efc38')
build() {
cd "${srcdir}"
@@ -24,6 +24,12 @@ build() {
make
}
+check(){
+ echo "Currently Does not build. If you have any ideas how to fix this please contact me: davidm@eagles.ewu.edu -Dave"
+
+ return 1
+}
+
package() {
cd "${srcdir}/build"
make DESTDIR="${pkgdir}" install