summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 747e7ddff20c..6fa59ca96711 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname='electron-cash'
pkgdesc='Lightweight Bitcoin Cash wallet'
-pkgver=4.2.13
+pkgver=4.2.14
secp256k1ver=0.20.9
pkgrel=1
url='http://www.electroncash.org/'
@@ -60,18 +60,15 @@ optdepends=(
provides=("${pkgname}")
conflicts=("${pkgname}")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Electron-Cash/Electron-Cash/archive/${pkgver}.tar.gz"
- "secp256k1-${secp256k1ver}.tar.gz::https://github.com/Bitcoin-ABC/secp256k1/archive/v${secp256k1ver}.tar.gz"
- "fix-bitpay-tests.patch")
-sha256sums=('b284f18d8f287b90b5f9e3f093774a8034b72080bb82f1a10ed4fe09de855e81'
- '68e84775e57da77e19ccb6b0dde6ca0882377bdd48ecc6da0047a70201ec64c8'
- 'SKIP')
+ "secp256k1-${secp256k1ver}.tar.gz::https://github.com/Bitcoin-ABC/secp256k1/archive/v${secp256k1ver}.tar.gz")
+sha256sums=('65e227bf34c329730660281f5db4b893b69b6d9f1fefe3061eeebb6fb7d78dec'
+ '68e84775e57da77e19ccb6b0dde6ca0882377bdd48ecc6da0047a70201ec64c8')
prepare() {
rmdir "Electron-Cash-${pkgver}/contrib/secp256k1"
ln -s "${PWD}/secp256k1-${secp256k1ver}" "Electron-Cash-${pkgver}/contrib/secp256k1"
sed -i 's/py\.test/pytest/' "Electron-Cash-${pkgver}/tox.ini"
- patch -Np1 -d "Electron-Cash-${pkgver}" < fix-bitpay-tests.patch
}
build() {