summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1862e8936a83..9a386e907498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,11 +9,19 @@
#
pkgname=electron-cash-git
+pkgdesc="Lightweight Bitcoin Cash wallet"
pkgver=2.9.2.r5.g8b2bdb6b
pkgrel=1
-pkgdesc="Lightweight Bitcoin Cash wallet"
url='http://www.electroncash.org/'
+install="${pkgname}.install"
arch=('any')
+license=('MIT')
+makedepends=(
+ 'git'
+ 'protobuf'
+ 'python2-pycurl'
+ 'python2-setuptools'
+)
depends=(
'hicolor-icon-theme'
'python2'
@@ -29,12 +37,6 @@ depends=(
'python2-requests'
'python2-six'
'qt4')
-makedepends=(
- 'git'
- 'protobuf'
- 'python2-pycurl'
- 'python2-setuptools'
-)
optdepends=(
'desktop-file-utils: update desktop icon'
'gtk-update-icon-cache: update desktop icon'
@@ -48,12 +50,10 @@ optdepends=(
'xdg-utils: update desktop icon'
'zbar: QR code reading support'
)
-license=('MIT')
-provides=('electron-cash')
-conflicts=('electron-cash')
+provides=("${pkgname/-git/}")
+conflicts=("${pkgname/-git/}")
source=('electron-cash::git+https://github.com/fyookball/electrum.git')
sha256sums=('SKIP')
-install=electron-cash.install
pkgver() {
cd "${pkgname/-git/}"
@@ -82,7 +82,7 @@ package() {
cd ${pkgname/-git/}
msg2 'Installing...'
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ python2 setup.py install --root="${pkgdir}"
msg2 'Cleaning up pkgdir...'
find "${pkgdir}" -type d -name .git -exec rm -r '{}' +