summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e80f010d3968
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Tim Diels <timdiels.m@gmail.com>
+
+pkgname=electroneum
+pkgver=0.11.0.0
+pkgrel=1
+pkgdesc='Secure, private, mobile based cryptocurrency '
+arch=('any')
+url='https://electroneum.com'
+license=('custom')
+makedepends=('cmake')
+depends=('boost' 'openssl' 'unbound')
+#checkdepends=('gtest')
+optdepends=(
+ 'miniupnpc: NAT punching'
+ 'libunwind: stack traces'
+ 'ldns: SSL toolkit'
+ 'expat: XML parsing'
+ 'doxygen: documentation'
+ 'graphviz: documentation'
+)
+source=("https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('0c459d99d18db514ba66f1df84e92daa')
+
+build() {
+ cd "$pkgname-$pkgver"
+ # Note: plain make fails with undeclared DIFFICULTY_TARGET_V1
+ # make release-static fails when compiling with e.g. -j8
+ make -j1 release-static
+}
+
+# Tests always fail due to DIFFICULT_TARGET_V1 error, so we don't run them
+#check() {
+# cd "$pkgname-$pkgver"
+# #make release-test
+#}
+
+package() {
+ cd "$pkgname-$pkgver"
+ # Note: make has no install target. Static build means we don't need to
+ # install lib.
+ install -dm755 "$pkgdir/usr/bin/"
+ install -Dm755 build/release/bin/* "$pkgdir/usr/bin/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+