summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 25 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6d6be882383..c4956bb6ac5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,62 @@
+# Maintainer: Daniel Case <daniel@dashlabs.org>
# Maintainer: Andy Kluger <AndyKluger@gmail.com>
# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=electrum-dash
_pkgname=Electrum-DASH
-pkgver=2.6.4
-pkgrel=2
+pkgver=3.0.6.3
+pkgrel=3
pkgdesc="Lightweight Bitcoin wallet, fork for DASH"
arch=('any')
depends=(
- 'python2-slowaes'
- 'python2-ecdsa'
- 'python2-pbkdf2'
- 'python2-requests'
- 'python2-qrcode'
- 'python2-protobuf'
- 'python2-dnspython'
- 'python2-jsonrpclib'
- 'python2-trezor'
- 'python2-x11_hash'
- 'python2-pyqt4'
+ 'python-pyaes'
+ 'python-ecdsa'
+ 'python-pbkdf2'
+ 'python-requests'
+ 'python-qrcode'
+ 'python-protobuf'
+ 'python-dnspython'
+ 'python-jsonrpclib-pelix'
+ 'python-trezor'
+ 'python-btchip'
+ 'python-x11_hash'
+ 'python-pyqt4'
# 'python2-pysocks'
# 'python2-pycryptodomex'
)
makedepends=(
- 'python2-pyqt4'
+ 'python-pyqt4'
# 'gettext'
# 'python2-setuptools'
# 'desktop-file-utils'
)
optdepends=(
- 'python2-btchip: BTChip hardware wallet support'
- 'python2-matplotlib: plot transaction history in graphical mode'
+ 'python-matplotlib: plot transaction history in graphical mode'
'zbar: QR code reading support'
)
url="https://electrum-dash.org"
license=(MIT)
-source=("https://electrum.dash.org/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('f8e1c9188e425ea4740125ba931b2ce034a97eaa3b37e4b589a22db8486a231b')
+source=("https://github.com/akhavr/electrum-dash/releases/download/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('45314890f229d0959b28fcb35d57d8d3416bf26c683bb629dec340fe6cb35105')
prepare() {
cd ${_pkgname}-${pkgver}
- find . -type f -exec sed -i 's#/usr/bin/python$#/usr/bin/python2#g' {} +
- find . -type f -exec sed -i 's#/usr/bin/env python$#/usr/bin/env python2#g' {} +
+ find . -type f -exec sed -i 's#/usr/bin/python$#/usr/bin/python3#g' {} +
+ find . -type f -exec sed -i 's#/usr/bin/env python$#/usr/bin/env python3#g' {} +
}
build() {
cd ${_pkgname}-${pkgver}
- pyrcc4 icons.qrc -o gui/qt/icons_rc.py
- python2 setup.py build
+ pyrcc5 icons.qrc -o gui/qt/icons_rc.py
+ python3 setup.py build
}
package() {
+ ls -lah
cd ${_pkgname}-${pkgver}
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ python3 setup.py install --root="${pkgdir}" --optimize=1
}