summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 28 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c11b9b6cce7..f6b8ae45d282 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,38 +8,40 @@
#
pkgname=electrum-git
-pkgver=20170309
+pkgver=20170826
pkgrel=1
pkgdesc="Lightweight Bitcoin wallet"
arch=('any')
depends=('hicolor-icon-theme'
- 'python2'
- 'python2-dnspython'
- 'python2-ecdsa'
- 'python2-jsonrpclib'
- 'python2-pbkdf2'
- 'python2-protobuf'
- 'python2-pyaes'
- 'python2-pyqt4'
- 'python2-pysocks'
- 'python2-qrcode'
- 'python2-requests'
- 'python2-six'
+ 'python'
+ 'python-dnspython'
+ 'python-ecdsa'
+ 'python-jsonrpclib-pelix'
+ 'python-pbkdf2'
+ 'python-protobuf'
+ 'python-pyaes'
+ 'python-pyqt4'
+ 'python-pysocks'
+ 'python-qrcode'
+ 'python-requests'
+ 'python-six'
'qt4')
makedepends=('gettext'
'git'
'protobuf'
- 'python2-pycurl'
- 'python2-setuptools')
+ 'python-pycurl'
+ 'python-setuptools'
+ 'python2'
+ 'python2-requests')
optdepends=('desktop-file-utils: update desktop icon'
'gtk-update-icon-cache: update desktop icon'
- 'python2-amodem: air-gapped transaction signing over audio modem'
- 'python2-btchip: Ledger hardware wallet support'
- 'python2-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
- 'python2-keepkey: KeepKey hardware wallet support'
- 'python2-matplotlib: plot transaction history in graphical mode'
- 'python2-rpyc: send commands to Electrum Python console from an external script'
- 'python2-trezor: Trezor hardware wallet support'
+ 'python-amodem: air-gapped transaction signing over audio modem'
+ 'python-btchip: Ledger hardware wallet support'
+ 'python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
+ 'python-keepkey: KeepKey hardware wallet support'
+ 'python-matplotlib: plot transaction history in graphical mode'
+ 'python-rpyc: send commands to Electrum Python console from an external script'
+ 'python-trezor: Trezor hardware wallet support'
'xdg-utils: update desktop icon'
'zbar: QR code reading support')
url="https://github.com/spesmilo/electrum"
@@ -59,25 +61,21 @@ build() {
cd ${pkgname%-git}
msg2 'Compiling icons...'
- pyrcc4 icons.qrc -o gui/qt/icons_rc.py
+ pyrcc4 icons.qrc -o gui/qt/icons_rc.py -py3
msg2 'Compiling protobuf description file...'
protoc --proto_path=lib/ --python_out=lib/ lib/paymentrequest.proto
msg2 'Creating translations...'
- python2 contrib/make_locale
+ ./contrib/make_locale
msg2 'Building...'
- python2 setup.py build
+ python setup.py build
}
package() {
cd ${pkgname%-git}
msg2 'Installing...'
- python2 setup.py install --root="$pkgdir" --optimize=1
-
- msg2 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
- find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+ python setup.py install --root="$pkgdir" --optimize=1
}