summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5c7cbcc0a83..f25da6a5e90b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Musee "lae" Ullah <lae(at)lae(dot)is>
pkgname=electrum-mona
-pkgver=3.0.6
+pkgver=3.1.1
pkgrel=1
pkgdesc="A lightweight Monacoin wallet"
arch=('any')
@@ -21,14 +21,20 @@ depends=('cython'
'python-certifi'
'gettext'
)
-optdepends=('python-matplotlib: for plot history')
+optdepends=('python-matplotlib: for plot history'
+ 'python-trezor: for Trezor hardware support'
+ 'python-btchip: for BTChip hardware support'
+ 'python-keepkey: for KeepKey hardware support')
makedepends=('python-pycurl')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/wakiyamap/${pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('043f9f2f70a671649639fb77aea1861673df355c1dfcbd1de6718226cb29fbafda55076f1be5cd9fdebae1a9bd9851d2c4cf33a541578076d58fa7dbed92de55')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/wakiyamap/${pkgname}/archive/${pkgver}.tar.gz"
+ '0001-remove-forced-optional-requirements-install.patch')
+sha512sums=('68ef5af532da98b9e99fde7f2755103b18143d4d77c467340877d2267af5b8d10885a14aca6e522b0bdf609199eafb41339ff7c38d7e896624510b3e3905f4fd'
+ '49c73d8716403ba6c9cde84c9ccd666ccd4ac6c9af1c98b7021018a7a629496f47b90182b040e2a7ef9cd4a9c86c31210ec74085e44e2a655b9bc2fbe690470f')
prepare() {
cd ${srcdir}/${pkgname}-${pkgver}/
pyrcc5 icons.qrc -o gui/qt/icons_rc.py
+ patch -Np1 -i "${srcdir}/0001-remove-forced-optional-requirements-install.patch"
}
build() {