summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 28 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf53be268a3b..71142ce5fb89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
# Maintainer: Raphael Scholer <rascholer@gmail.com>
_pkgname='elementary-xfce'
pkgname="${_pkgname}-icons-git"
-pkgver=0.10.r2.g9ff56ee0
-pkgrel=2
+pkgver=0.12.r20.g149753da
+pkgrel=1
pkgdesc='Elementary icon-theme with improved Xfce support'
arch=('any')
url="https://github.com/shimmerproject/${_pkgname}"
license=('GPL2')
-makedepends=('git')
+makedepends=('git' 'gtk3' 'optipng')
depends=('adwaita-icon-theme')
conflicts=("${_pkgname}-icons")
provides=("${_pkgname}-icons")
-options=(!strip)
source=("git+${url}")
sha256sums=('SKIP')
@@ -20,14 +19,34 @@ pkgver() {
git describe --long --tags | sed "s/^${_pkgname}.//;s/\([^-]*-g\)/r\1/;s/-/./g"
}
-package() {
- install -m 755 -d "${pkgdir}/usr/share/icons"
+prepare() {
+ cd "${_pkgname}"
+
+ # Only run make's build target once.
+ sed -e 's/install: build/install:/' -i Makefile.in
+ # Generation of caches is done by an ALPM hook.
+ sed -e '/@echo .*The icon-theme cache/d' -i Makefile.in
+}
+
+build() {
cd "${_pkgname}"
- cp -r ${_pkgname}{,-dark{,er,est}} "${pkgdir}/usr/share/icons/"
+
+ ./configure --prefix="/usr/"
+ make -j1
+}
+
+package() {
+ cd "${_pkgname}"
+
+ make DESTDIR="${pkgdir}" install
# Remove unneeded files
- cd "${pkgdir}/usr/share/icons"
- rm ${_pkgname}{,-dark{,er,est}}/{AUTHORS,CONTRIBUTORS,LICENSE}
+ find "${pkgdir}/usr/share/icons" \
+ \( \
+ -name 'AUTHORS' \
+ -o -name 'CONTRIBUTORS' \
+ -o -name 'LICENSE' \
+ \) -delete
}
# vim:set ts=2 sw=2 et: