summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64ee3efbd400..24ccf8445032 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Lukas Werling <lukas.werling@gmail.com>
pkgname=elm-platform
pkgver=0.18.0
-pkgrel=3
+pkgrel=4
pkgdesc="Bundle of all core development tools for the Elm language."
arch=('i686' 'x86_64')
url="http://elm-lang.org"
license=('BSD3')
depends=('gmp' 'zlib')
+optdepends=('nodejs: for elm-repl')
makedepends=('stack-static' 'patchelf')
-conflicts=('nodejs-elm')
+conflicts=('nodejs-elm' 'elm-platform-bin')
source=(
elm-compiler-${pkgver}.zip::https://github.com/elm-lang/elm-compiler/archive/${pkgver}.zip
elm-package-${pkgver}.zip::https://github.com/elm-lang/elm-package/archive/${pkgver}.zip
@@ -27,7 +28,7 @@ sha256sums=('911109bbedf13c5a5c154ff8b60087b43cfd8be5e165df09b4e8f532a9f22fcd'
prepare() {
cd "$srcdir"
- ln -sf elm-compiler-${pkgver} elm-compiler
+ ln -sf compiler-${pkgver} elm-compiler
ln -sf elm-package-${pkgver} elm-package
ln -sf elm-make-${pkgver} elm-make
ln -sf elm-reactor-${pkgver} elm-reactor
@@ -36,8 +37,10 @@ prepare() {
build() {
cd "$srcdir"
+ mkdir -p .stack
- stack build --install-ghc
+ stack setup --stack-root "$PWD/.stack"
+ stack build --stack-root "$PWD/.stack"
binpath="$(stack path --local-install-root)/bin"
for bin in elm elm-make elm-package elm-reactor elm-repl; do