summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b479f8716d1b..41c2d234d350 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,29 @@
pkgname=elmerfem
pkgver=9.0
-pkgrel=1
+pkgrel=2
pkgdesc="A finite element software for multiphysical problems"
arch=('x86_64')
url="http://www.elmerfem.org"
license=('GPL')
-depends=('arpack' 'blas' 'qt5-script' 'netcdf-fortran' 'mmg' 'vtk' 'qwt' 'glu')
+depends=('arpack' 'blas' 'qt5-script' 'netcdf-fortran' 'mmg' 'qwt' 'glu')
makedepends=('gcc-fortran' 'cmake')
conflicts=('elmerfem-git')
options=(!emptydirs !makeflags)
source=("https://github.com/ElmerCSC/$pkgname/archive/release-$pkgver.tar.gz"
+ "$pkgname.desktop"
"ElmerIce.patch"
- "$pkgname.desktop")
+ "DCRComplexSolve.patch")
sha256sums=('08c5bf261e87ff37456c1aa0372db3c83efabe4473ea3ea0b8ec66f5944d1aa0'
+ 'f4b39389e5f258c7860b8d7a6b171fb54bf849dc772f640ac5e7a12c7a384aca'
'90287c988ac4f5beedf5221e81f624799ec3253c63a30695e1873044ac5a6515'
- 'f4b39389e5f258c7860b8d7a6b171fb54bf849dc772f640ac5e7a12c7a384aca')
+ 'fe117a9d803b7a12525d144fae936e1d3d7a3444c5b5a5697f95f772486a2db0')
prepare() {
cd "$srcdir/$pkgname-release-$pkgver"
mkdir ../build
patch -p0 < "$srcdir/ElmerIce.patch"
+ patch -p0 < "$srcdir/DCRComplexSolve.patch"
sed -i '/#include <QPainter>/a #include <QPainterPath>' ElmerGUI/Application/twod/renderarea.cpp
}
@@ -44,6 +47,7 @@ build() {
-DWITH_QT5=ON \
-DWITH_ScatteredDataInterpolator=ON \
-DWITH_VTK=ON \
+ -DWITH_MKL=OFF \
-DOpenGL_GL_PREFERENCE=GLVND
make all
}
@@ -60,7 +64,8 @@ package() {
install -dv share/{applications,pixmaps,licenses/$pkgname}
# Icon and desktop files
- install -D -m644 "$srcdir/$pkgname-release-$pkgver/ElmerGUI/Application/images/logo.png" share/pixmaps/$pkgname.png
+ install -D -m644 "$srcdir/$pkgname-release-$pkgver/ElmerGUI/Application/images/logo.png" \
+ share/pixmaps/$pkgname.png
install -D -m644 "$srcdir/$pkgname.desktop" share/applications
# Clean up and move stuff in place