summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8410901e12c5..cfe19164637a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: tequa
+# Maintainer: tequa
pkgname=eltclsh
pkgver=1.16
-pkgrel=1
+pkgrel=2
epoch=
-pkgdesc="eltclsh (editline tcl shell) is an interactive shell for the TCL programming language"
+pkgdesc="interactive shell for the TCL programming language"
arch=('i686' 'x86_64' 'armv7h')
url="http://homepages.laas.fr/mallet/soft/shell/eltclsh"
license=('BSD')
@@ -19,11 +19,20 @@ backup=()
options=()
install=
changelog=
-source=("http://distfiles.openrobots.org/eltclsh/$pkgname-$pkgver.tar.gz")
+source=(
+ "tools.patch"
+ "http://distfiles.openrobots.org/eltclsh/$pkgname-$pkgver.tar.gz"
+)
noextract=()
-md5sums=('a13130374265b871ff17fdec357aee60')
+md5sums=('af3e1e0eb06d1cebed7d4c1bdae5ff29'
+ 'a13130374265b871ff17fdec357aee60')
validpgpkeys=()
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}/tools.patch"
+}
+
build() {
cd "$pkgname-$pkgver"
./configure --prefix=/usr