summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fab49a696ece..2460a4d5665d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-company-mode
-pkgver=0.9.3
+pkgver=0.9.4
pkgrel=1
pkgdesc="Modular in-buffer completion framework for Emacs"
url="http://company-mode.github.io"
@@ -10,16 +11,16 @@ license=('GPL3')
depends=('emacs')
makedepends=('git')
provides=('emacs-company-mode')
-source=("https://github.com/company-mode/company-mode/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/company-mode/company-mode/archive/${pkgver}.tar.gz")
+sha256sums=('fd2662a452aa31644d0e7615e9aeff236f0c8e09b13b0371c400b1b0bc0d1e73')
build() {
- cd "${srcdir}/company-mode-${pkgver}"
+ cd company-mode-${pkgver}
emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
}
package() {
- cd "${srcdir}/company-mode-${pkgver}"
- install -d "${pkgdir}/usr/share/emacs/site-lisp/company-mode"
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/company-mode/"
+ cd company-mode-${pkgver}
+ install -d "${pkgdir}"/usr/share/emacs/site-lisp/company-mode
+ install -m644 *.el{c,} "${pkgdir}"/usr/share/emacs/site-lisp/company-mode/
}