summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6966a2b27405
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-evil-surround
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="you will be surrounded (surround.vim for evil, the extensible vi layer)"
+url="https://github.com/timcharper/evil-surround"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-evil')
+makedepends=('git')
+provides=('emacs-evil-surround')
+source=("https://github.com/timcharper/evil-surround/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/evil-surround-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/evil-surround-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/evil-surround"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/evil-surround/"
+}