summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fca60781ec3c..8e46526c7002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=emacs-gnuplot-mode-git
-pkgver=0.7.0.29.g21f9046
-pkgrel=2
+pkgver=0.7.0.34.ga406143
+pkgrel=1
pkgdesc="Emacs-mode for writing gnuplot scripts"
arch=('any')
url="https://github.com/bruceravel/gnuplot-mode"
license=('GPL2')
makedepends=('git' 'emacs' 'texlive-bin') # latter only for gpelcard.pdf
-# should also work with xemacs or sxemacs
-source=("git+https://github.com/bruceravel/gnuplot-mode.git")
+source=("git+$url.git")
md5sums=('SKIP')
_gitname="gnuplot-mode"
pkgver() {
- cd "$srcdir"/"$_gitname"
+ cd $_gitname
git describe --tags | sed 's|-|.|g'
}
build() {
- cd "$srcdir"/"$_gitname"
+ cd $_gitname
autoreconf
./configure --with-lispdir=/usr/share/emacs/site-lisp \
EMACS=emacs # ... or xemacs or sxemacs
@@ -27,12 +27,12 @@ build() {
}
package() {
- cd "$srcdir/$_gitname"
+ cd $_gitname
make DESTDIR="$pkgdir/" install
for _i in .tex .pdf
do
install -Dm644 gpelcard${_i} \
- $pkgdir/usr/share/doc/emacs-gnuplot-mode/gpelcard${_i}
+ "$pkgdir"/usr/share/doc/emacs-gnuplot-mode/gpelcard${_i}
done
}