summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de5a878e333d..f422d00219eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,22 @@
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
pkgname='emacs-mozc'
-pkgver=2.28.4960.102
+pkgver=2.28.4990.102
pkgrel=1
pkgdesc='Mozc module for Emacs'
arch=('x86_64')
url='https://github.com/google/mozc'
-license=('Apache' 'BSD' 'LGPL' 'custom')
-depends=('emacs' 'mozc>=2.28.4960.102')
+license=('Apache' 'GPL' 'LGPL' 'MIT' 'custom')
+depends=('emacs' 'mozc>=2.28.4990.102')
makedepends=('bazel' 'git' 'python' 'qt5-base')
options=(!distcc !ccache)
-source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=7ec82c9356dbd5e15736627cfef05ec0f2c9bb9b")
+source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=811cb8c7606a4732a83abb89752664eb23728623")
sha256sums=('SKIP')
prepare() {
cd ${pkgname}-git/src
git submodule update --init --recursive
-
- # Temp fix for Bazel 6.0.0
- sed -i -e 's|@bazel_tools//platforms|@platforms//os|' tools/cc_target_os/BUILD.bazel
}
build() {
@@ -37,7 +34,7 @@ package() {
cd ${pkgname}-git/src
install -Dm644 ../LICENSE ${pkgdir}/usr/share/licenses/emacs-mozc/LICENSE
- install -Dm644 data/installer/credits_en.html ${pkgdir}/usr/share/licenses/emacs-mozc/credits_en.html
+ install -Dm644 data/installer/credits_en.html ${pkgdir}/usr/share/licenses/emacs-mozc/Submodules
install -Dm755 bazel-bin/unix/emacs/mozc_emacs_helper ${pkgdir}/usr/bin/mozc_emacs_helper
install -Dm644 unix/emacs/mozc.el ${pkgdir}/usr/share/emacs/site-lisp/mozc.el