summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c895690b4e07..141d0b32c817 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,7 +49,7 @@ MOLD="YES" # Use the mold linker.
# Notice that it will always be used.
JIT="YES" # Enable native just-in-time compilation. Use libgccjit,
- # which is already included in Arch's gcc package.
+ # which is in testing repo for now.
#
# This compiles only performance critical elisp files.
#
@@ -166,6 +166,14 @@ if [[ $CLANG == "YES" ]]; then
fi
fi
+if [[ $JIT == "YES" ]]; then
+ if [[ $CLI == "YES" ]]; then
+ depends_nox+=( 'libgccjit' );
+ else
+ depends+=( 'libgccjit' );
+ fi
+fi
+
if [[ $CLI == "YES" ]]; then
depends=("${depends_nox[@]}");
elif [[ $NOTKIT == "YES" ]]; then