summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7aaa18d7476c..c895690b4e07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,9 @@ MOLD="YES" # Use the mold linker.
# This is the default linker.
# Notice that it will always be used.
-JIT="YES" # Enable native just-in-time compilation. libgccjit is in AUR.
+JIT="YES" # Enable native just-in-time compilation. Use libgccjit,
+ # which is already included in Arch's gcc package.
+ #
# This compiles only performance critical elisp files.
#
# To compile all elisp on demand, add
@@ -164,14 +166,6 @@ if [[ $CLANG == "YES" ]]; then
fi
fi
-if [[ $JIT == "YES" ]]; then
- if [[ $CLI == "YES" ]]; then
- depends_nox+=( 'libgccjit' );
- else
- depends+=( 'libgccjit' );
- fi
-fi
-
if [[ $CLI == "YES" ]]; then
depends=("${depends_nox[@]}");
elif [[ $NOTKIT == "YES" ]]; then