summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 4 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e93f1e02946..ceada8138f49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,28 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-sly-git
-pkgver=1.0.0.beta.498.gc338f22c
+pkgver=2.21.40.g710d4be4
pkgrel=1
pkgdesc="Common Lisp IDE for Emacs. Fork of slime."
arch=('any')
-url="https://github.com/capitaomorte/sly"
+url="https://github.com/joaotavora/sly"
license=('custom')
depends=('emacs' 'gawk')
makedepends=('git')
provides=('sly' 'emacs-sly')
conflicts=('sly' 'emacs-sly')
-source=("emacs-sly::git+https://github.com/capitaomorte/sly.git")
+source=("emacs-sly::git+https://github.com/joaotavora/sly.git")
md5sums=('SKIP')
options=('!makeflags')
pkgver() {
cd ${pkgname%-git}
- echo $(git describe --tags | sed 's|-|.|g')
+ echo $(git describe --tags | cut -c15- | tr - .)
}
-# prepare () {
-# cd ${pkgname%-git}/contrib
-# # some files cannot be byte-compiled
-# mv sly-fancy.el doof1
-# mv sly-stickers.el doof2
-# }
-
build() {
cd ${pkgname%-git}
make
- # reverting the prepare step to include the not byte-compiled files
- # cd contrib
- # mv doof1 sly-fancy.el
- # mv doof2 sly-stickers.el
}
package() {