summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81b82bfd9aec..33906de49feb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: sballert <sballert@posteo.de>
+# Contributor: sballert <sballert@posteo.de>
# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-swiper
pkgver=0.10.0
-pkgrel=1
-pkgdesc="Ivy - a generic completion frontend for Emacs, Swiper - isearch with an overview, and more. Oh, man!"
+pkgrel=2
+pkgdesc="Ivy - a generic completion frontend for Emacs, Swiper - isearch with an overview"
url="https://github.com/abo-abo/swiper"
arch=('any')
license=('GPL3')
@@ -12,16 +13,16 @@ depends=('emacs')
makedepends=('git')
provides=('emacs-swiper')
conflicts=('emacs-swiper')
-source=("https://github.com/abo-abo/swiper/archive/${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/abo-abo/swiper/archive/${pkgver}.tar.gz")
sha256sums=('b507579202e438103f2bd1925b4a5ddb9dccb85efdca5faf786d07f58521816e')
build() {
- cd "${srcdir}/swiper-${pkgver}"
+ cd "swiper-${pkgver}"
make clean test compile
}
package() {
- cd "${srcdir}/swiper-${pkgver}"
+ cd "swiper-${pkgver}"
install -d "${pkgdir}/usr/share/emacs/site-lisp/swiper"
install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/swiper/"
}