summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abd5f20f1ea6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-swiper
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="Ivy - a generic completion frontend for Emacs, Swiper - isearch with an overview, and more. Oh, man!"
+url="https://github.com/abo-abo/swiper"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-swiper')
+conflicts=('emacs-swiper')
+source=("https://github.com/abo-abo/swiper/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/swiper-${pkgver}"
+ make clean test compile
+}
+
+package() {
+ cd "${srcdir}/swiper-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/swiper"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/swiper/"
+}