summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddaa5610632f..a0fe6d6d62a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Anna Schumaker <anna@nowheycreamery.com>
pkgname=emmental
-pkgver=3.0
+pkgver=3.0.1
pkgrel=1
pkgdesc='The cheesy music player'
url='https://www.git.nowheycreamery.com/anna/emmental'
@@ -11,13 +11,14 @@ makedepends=(git desktop-file-utils)
optdepends=(gst-plugins-good gst-plugins-bad gst-plugins-ugly)
checkdepends=(flake8 python-pytest python-pytest-timeout python-pytest-subtests)
source=("https://git.nowheycreamery.com/anna/emmental/archive/emmental-$pkgver.tar.gz")
-sha256sums=(f80a79f4a966a92496658aa683e5f40cd799839ff0af3e4dfba140276f6ebdfd)
+sha256sums=(1e27de1bb6a4785861810de907dfc33928c6d348a3a18b3d4aea370724a6c8a2)
prepare() {
cd $pkgname
if [ ! -f "mpris-spec/Makefile" ]; then
git clone https://gitlab.freedesktop.org/mpris/mpris-spec.git
fi
+ mv emmental.desktop com.nowheycreamery.emmental.desktop
}
build() {
@@ -30,8 +31,7 @@ package() {
cd $pkgname
make PREFIX="$pkgdir/usr" install
sed -i "s|$pkgdir||" $pkgdir/usr/bin/emmental
- sed -i "s|$pkgdir||" $pkgdir/usr/share/applications/emmental.desktop
- desktop-file-edit --set-key=StartupWMClass --set-value=emmental.py $pkgdir/usr/share/applications/emmental.desktop
+ sed -i "s|$pkgdir||" $pkgdir/usr/share/applications/com.nowheycreamery.emmental.desktop
rm -f "$pkgdir/usr/share/applications/mimeinfo.cache"
}