summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38a3a54b576f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: ccat3z <c0ldcat3z@gmail.com>
+
+pkgname=emojify-git
+pkgver=2.1.0.r11.gb6e95a0
+pkgrel=1
+pkgdesc='Emoji on the command line.'
+arch=('any')
+url='https://github.com/mrowa44/emojify'
+depends=('bash')
+provides=('emojify')
+conflicts=('emojify')
+license=('MIT')
+source=("${pkgname%-git}::git+https://github.com/mrowa44/emojify.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-git}/emojify" "${pkgdir}/usr/bin/emojify"
+ install -Dm644 "${srcdir}/${pkgname%-git}/LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}