summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a57b68c8d301..075c9e99297d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,39 @@
# Maintainer: Luke Arms <luke@arms.to>
pkgname=emote
-pkgver=3.0.3
-_pkgref=ff40e3d66b251aaf2e91116ba177e59f087e1021
-pkgrel=5
+pkgver=3.1.0
+_pkgref=1539e91d02c93e1438a2912940f687ce40dc2bfe
+_openmojiref=90c4aa28c902212d7e784f388ff5d1c15fcac617
+pkgrel=2
url="https://github.com/tom-james-watson/Emote"
pkgdesc="Emoji Picker for Linux written in GTK3"
arch=('any')
license=('GPL3')
-depends=('python' 'gtk3' 'python-gobject' 'python-xlib' 'python-manimpango' 'libkeybinder3' 'xdotool')
+depends=('python' 'gtk3' 'python-gobject' 'python-manimpango' 'libkeybinder3' 'xdotool')
makedepends=('python-setuptools' 'python-pipenv')
source=(
"https://github.com/tom-james-watson/Emote/archive/${_pkgref}.tar.gz"
+ "https://raw.githubusercontent.com/hfg-gmuend/openmoji/${_openmojiref}/data/openmoji.csv"
'setup.py'
'fix-skin-tone-static-path.patch'
)
sha512sums=(
'SKIP'
+ 'b726a0e89142da3bb0b67ca2b7fd1d7002832e01569eeb2de4a64abfd14cb3d7da315b086d171fe8dce11e9064c6c7922aa33863bff77b9073e505e91fe7e6b7'
'ef8caea8ad9e9bc0487dd8c816561027adda743c1e8e2779a64e7ae99fb227c820f31ef9c87fb910bae7a8ffc623e5e2e1a53a8c69ce0a35ad96557e97a5a949'
- '52d3dce0cecfe62ccc4469b4b35b27c8332d6dce2d1e2dd5603c85a3025fb4a415df303eaaace5579c4204923cbd8d86846deb1026a01f8b201452453c61746f'
+ '76e5a84646dafb37b6ee83e564aefd5ccaca619d47802d2ea4e4190ec2af5a0c485aa6d9a2f8969732ca7156c458fd18105614b6826ade834943a8c19c3d8e3f'
)
-build() {
+prepare() {
# Replace setup.py
mv -f "$srcdir/setup.py" "$srcdir/Emote-$_pkgref/setup.py"
# Fix skin tone and `static/` path issues when not running as a snap
patch -d "$srcdir/Emote-$_pkgref" -p1 <"$srcdir/fix-skin-tone-static-path.patch"
+ cd "$srcdir/Emote-$_pkgref"
+ ./update-emojis "$srcdir/openmoji.csv"
+}
+
+build() {
# Move static files into the library
mv -T "$srcdir/Emote-$_pkgref/static" "$srcdir/Emote-$_pkgref/emote/static"
# Fix .desktop file