summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b9c316e7b29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Carson Rueter <roachh at proton mail dot com>
+
+pkgname=emptty-openrc
+pkgver=20210312
+pkgrel=1
+pkgdesc="OpenRC emptty init script"
+arch=('any')
+url="https://github.com/tvrzna/emptty"
+license=('MIT')
+provides=('emptty-openrc')
+source=("emptty.initd")
+sha256sums=('05ab1fd1fc81d27a07240fe942e2724351314afb4b9a0ee594c0f38cad6cdfac')
+
+pkgver() {
+ date +%Y%m%d
+}
+
+_inst_initd(){
+ install -Dm755 ${srcdir}/$1.initd ${pkgdir}/etc/init.d/$1
+
+ sed -e 's|#!/sbin/openrc-run|#!/usr/bin/openrc-run|g' \
+ -e 's|/var/run|/run|g' \
+ -e 's|/usr/sbin|/usr/bin|g' \
+ -i ${pkgdir}/etc/init.d/$1
+}
+
+package(){
+ _inst_initd 'emptty'
+}