summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 839eb45f2648..b021e1dc51b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
pkgname=('enchant-pure')
_pkgname=enchant
-pkgver=1.6.0
-pkgrel=4
+pkgver=1.6.1
+pkgrel=1
pkgdesc="A wrapper library for pure and generic spell checking for all languages, supporting Aspell and Myspell/Hunspell backend engines"
-url="http://www.abisource.com/enchant/"
+url="https://github.com/AbiWord/enchant"
arch=('any')
license=('LGPL')
@@ -17,19 +17,21 @@ provides=("${_pkgname}")
conflicts=("${_pkgname}")
options=('!libtool')
-source=("http://www.abisource.com/downloads/${_pkgname}/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
- "warnings-fix.patch")
-sha512sums=('0ca1634bb783df51512df4abecc89abdadee6baf7330d6e5f90cc15d10779896a3521a1c079ecc07e4df4f7a018ce398cca9d0125a7845a314a059840ebc9137'
- 'de32bce6c0b364eaf8142fd65c1a9afa0909dcfba4c17ad10626fb38db355f314baade75c6d5f4b3fbedd04917400b2e3d10b898cfe7a006883b2e32520ab79e')
+source=("https://github.com/AbiWord/${_pkgname}/archive/${_pkgname}-${pkgver//./-}.tar.gz"
+ "warnings-fix.patch")
+sha512sums=('971462f8228a1033536a461ddcd9d4c124df5e9b791bd0e996173f56909345639e37cec0950ee3d9f320d985249df4b492eda70e659386c160a240c7b8572e06'
+ 'a504286ae22ccbc0b3da009c14c8c85506f8b013305808f1dd664f12a346db354d290e9873a54518e3b56687fef75a474e5b385eed4c81f4227bc25d1fc92e7c')
prepare() {
+ mv "${srcdir}/${_pkgname}-${_pkgname}-${pkgver//./-}/" "${srcdir}/${_pkgname}-${pkgver}"
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -p1 -i ../warnings-fix.patch
}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- ./configure --prefix=/usr --disable-static --disable-ispell --disable-hspell --with-myspell-dir=/usr/share/myspell
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-static=no --disable-ispell --disable-hspell --disable-voikko --with-myspell-dir=/usr/share/myspell
make
}