summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21ebc2212368..5dd0b2dd79e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
pkgname=enlighten-git
pkgver=0
-pkgrel=3
+pkgrel=2
pkgdesc='A small tool to modify LCD backlight brightness'
url='https://github.com/HalosGhost/enlighten'
arch=('i686' 'x86_64')
license=('GPL3')
-makedepends=('git' 'clang' 'python-docutils' 'python-sphinx')
+makedepends=('git' 'clang' 'python-docutils')
source=('git+https://github.com/HalosGhost/enlighten.git')
sha256sums=('SKIP')
pkgver () {
cd enlighten
- printf '0.r%s.%s' "$(git rev-list --count HEAD)" "$(git log -1 --pretty=format:%h)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare () {