summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f0e22682de3..53f896cc7b97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-pkgname='enroot'
+pkgname='enroot-git'
pkgver=2.2.0
-pkgrel=2
+pkgrel=1
pkgdesc='A simple yet powerful tool to turn traditional container/OS images into unprivileged sandboxes.'
url='https://github.com/NVIDIA/enroot'
arch=(x86_64)
@@ -8,10 +8,18 @@ license=(BSD)
makedepends=(git gcc make libtool)
depends=(jq parallel squashfs-tools)
optdepends=(fuse-overlayfs-git libnvidia-container-tools pigz pv squashfuse)
+conflicts=(enroot)
+provides=(enroot)
install='enroot.install'
-source=("git+https://github.com/NVIDIA/enroot.git#tag=v${pkgver}")
+source=("git+https://github.com/NVIDIA/enroot.git#branch=master")
sha256sums=(SKIP)
+pkgver() {
+ cd enroot
+ # Remove leading "v"; add "r" before commit count; convert dashes to dots.
+ git describe --long --tags | sed 's/^v// ; s/\([^-]*-g\)/r\1/ ; s/-/./g'
+}
+
build() {
cd 'enroot'
CPPFLAGS="-DALLOW_SPECULATION -DINHERIT_FDS" make prefix='' exec_prefix=/usr datarootdir=/usr/share
@@ -21,7 +29,7 @@ package() {
cd 'enroot'
DESTDIR="$pkgdir/" make install prefix='' exec_prefix=/usr datarootdir=/usr/share
mkdir -p "${pkgdir}/usr/share/bash-completion/completions"
- mv "${pkgdir}/usr/share/enroot/enroot.bash_completion" "${pkgdir}/usr/share/bash-completion/completions/enroot"
+ mv "${pkgdir}/usr/share/enroot/bash_completion" "${pkgdir}/usr/share/bash-completion/completions/enroot"
}
backup=(etc/enroot/enroot.conf)