summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a7f88fc5d8f..517c982c93b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Tinu Weber <martin.weber@epfl.ch>
pkgname=epfl-menu-git
+_pkgname=epfl-menu
pkgver=r16.2406823
-pkgrel=1
+pkgrel=2
pkgdesc='Pretty-print the lunch and supper menus at the EPFL'
arch=('any')
url='https://github.com/gcmalloc/epfl-menu'
@@ -12,18 +13,18 @@ source=('git+https://github.com/gcmalloc/epfl-menu')
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgname"
python3 setup.py build
}
package() {
depends=('python-beautifulsoup4' 'python-urllib3')
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgname"
python3 setup.py install --root="$pkgdir" --optimize=1
mv "$pkgdir"/usr/bin/menu "$pkgdir"/usr/bin/epfl-menu
mkdir -p "$pkgdir"/usr/share/licenses/epfl-menu