summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 18 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 297ee14fc3a8..a1c3612dd0bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,42 @@
# Maintainer: Que Quotion <quequotion@bugmenot.com>
# Contributor: Adria Arrufat <adria DOT arrufat+aur AT protonmail DOT ch>
-_pkgname=epiphany
-pkgname=$_pkgname-pantheon-bzr
-ephyver=3.27.90-1ubuntu1
-ubunturel=bionic
-pkgver=3.27.90.1ubuntu1.r20
-pkgrel=6
-pkgdesc="A GNOME web browser based on the WebKit rendering engine, with Elementary OS patches"
-url="http://www.gnome.org/projects/epiphany/"
+pkgname=epiphany-pantheon
+pkgver=3.28.0.1+1ubuntu1+r21.dbc305d50
+pkgrel=1
+pkgdesc="A GNOME web browser based on the WebKit rendering engine, with elementary OS patches"
+url="https://gitlab.gnome.org/GNOME/epiphany/"
arch=('i686' 'x86_64')
license=('GPL')
depends=('webkit2gtk>=2.19.4' gcr libhttpseverywhere libdazzle gst-libav)
makedepends=(meson docbook-xml startup-notification lsb-release
- gobject-introspection yelp-tools autoconf-archive appstream-glib bzr)
+ gobject-introspection yelp-tools autoconf-archive appstream-glib)
groups=(pantheon-unstable pantheon-qq)
-replaces=(epiphany)
+replaces=(epiphany-pantheon-bzr)
provides=(epiphany epiphany-sync)
conflicts=(epiphany)
-source=("bzr+lp:~elementary-os/elementaryos/os-patch-epiphany-browser-${ubunturel}"
+source=("git+https://github.com/elementary/os-patches.git#branch=epiphany-browser-bionic-patched"
epiphany-sync{,.service})
sha256sums=('SKIP'
'cf90f3ea93fff8c61f82da40c8d07d5db2f33dc9a0d91408a6ffc4142bbedd20'
'ce1ac321d7bf9d88638634a141dfcb99119fc59ee44c4892e0874608e85006ba')
pkgver() {
- cd "os-patch-epiphany-browser-${ubunturel}"
+ cd "os-patches"
- echo "${ephyver/-/.}.r$(bzr revno)"
+ printf "3.28.0.1+1ubuntu1+r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "os-patch-epiphany-browser-${ubunturel}"
- [ -d build ] && rm -rf build
- arch-meson build -Denable_https_everywhere=true
- ninja -C build
+ cd "os-patches"
+ [ -d build ] && rm -rf build
+ arch-meson build -Denable_https_everywhere=true
+ ninja -C build
}
package() {
- cd "os-patch-epiphany-browser-$ubunturel"
- DESTDIR="${pkgdir}" ninja -C build install
- install -Dm 755 {"${srcdir}","${pkgdir}"/usr/bin}/epiphany-sync
- install -Dm 644 {"${srcdir}","${pkgdir}"/usr/lib/systemd/user}/epiphany-sync.service
+ cd "os-patches"
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm 755 {"${srcdir}","${pkgdir}"/usr/bin}/epiphany-sync
+ install -Dm 644 {"${srcdir}","${pkgdir}"/usr/lib/systemd/user}/epiphany-sync.service
}