summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9428f9dcc0d4..b2d2865ebdd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dennis van der Schagt <dennisschagt@gmail.com>
pkgname=eprosima-fast-dds
pkgver=2.11.0
-pkgrel=1
+pkgrel=2
pkgdesc="eProsima's Fast-DDS implementation"
arch=('x86_64')
url="https://github.com/eProsima/Fast-DDS"
@@ -17,11 +17,22 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/eProsima/Fast-DDS/archive/v${pkgver}.tar.gz")
+source=(
+ "https://github.com/eProsima/Fast-DDS/archive/v${pkgver}.tar.gz"
+ "001-include-cstdint.patch"
+)
noextract=()
-sha256sums=('afaf43fbee90d6dbecbbe7c363860c4963f8db2f4be94dc7c61a27bfdf841b83')
+sha256sums=(
+ 'afaf43fbee90d6dbecbbe7c363860c4963f8db2f4be94dc7c61a27bfdf841b83'
+ '9656a7c2780040a922ecd85b9ba046ec72375a394b5ae199d570d1c1b7e82abf'
+)
validpgpkeys=()
+prepare() {
+ cd Fast-DDS-${pkgver}
+ patch --forward --strip=1 --input="${srcdir}/001-include-cstdint.patch"
+}
+
build() {
cd "Fast-DDS-$pkgver"
cmake -B build \