summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28c64f1406ff..8895419e4c48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,27 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: quellen <lodgerz@gmail.com>
-pkgname=epub2txt
+pkgname='epub2txt'
+_pkgname="${pkgname}2"
pkgver=2.01
-pkgrel=1
+pkgrel=2
pkgdesc='Extract text from EPUB documents'
arch=('x86_64')
url='https://github.com/kevinboone/epub2txt2'
license=('GPL3')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+conflicts=("${_pkgname}")
+source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha256sums=('82c96c713c8a6e10d7b37e96db83a9d5f50fcb4b65034b4a1df1024776b6591f')
build() {
- make -C "${pkgname}2-${pkgver}"
+ make -C "${_pkgname}-${pkgver}"
}
package() {
- make DESTDIR="${pkgdir}" -C "${pkgname}2-${pkgver}" install
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}2-${pkgver}/README.md"
+ cd "${_pkgname}-${pkgver}"
+ install -Dm755 -t "${pkgdir}/usr/bin" "${pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/man/man1" "man1/${pkgname}.1"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
}
# vim: ts=2 sw=2 et: