summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65cba2075735..1c4737948f4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,16 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
_pkgver=2.1.6-beta
-pkgname=espanso-wayland
+pkgname=espanso
pkgver=2.1.6
pkgrel=1
pkgdesc="Cross-platform Text Expander written in Rust"
arch=(x86_64)
url="https://espanso.org/"
license=("GPL3")
-depends=("libnotify" "wxgtk2" "libxkbcommon" "wl-clipboard")
+depends=("xdotool" "xclip" "libxtst" "libnotify" "wxgtk2")
makedepends=("rust" "git" "cmake" "cargo-make" "rust-script")
-provides=("${pkgname%-wayland}")
-conflicts=("${pkgname%-wayland}")
options=("!lto") # fails with LTO as of 2022-03
-install=espanso-wayland.install
source=("git+https://github.com/federico-terzi/espanso.git#tag=v${_pkgver}")
sha512sums=('SKIP')
@@ -29,7 +26,7 @@ prepare() {
build() {
cd "espanso"
- cargo make --env NO_X11=true --profile release build-binary
+ cargo make --profile release build-binary
}
package() {