aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d59dd4a5ae5..0a952712685c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,35 @@
# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=ess-epics
-pkgver=7.0.5
+pkgver=2.0.3.r8.gb4369db
pkgrel=1
-pkgdesc="Experimental Physics and Industrial Control System -- ESS falvor"
+pkgdesc="Experimental Physics and Industrial Control System -- ESS flavour"
arch=('any')
url="http://www.aps.anl.gov/epics/"
provides=('epics')
conflicts=('epics')
-license=('EPICS Open License')
-makedepends=('rpcsvc-proto' 'tree' 'git')
-depends=('libtirpc-compat' 'tclx' 'tcl' 'aravis' 'glibmm' 'libtirpc' 'readline' 'libxt' 'libxmu' 'libxpm' 'pcre' 'net-snmp' 're2c' 'darcs' 'python2' 'netcdf' 'hdf5' 'libpng' 'bzip2' 'libxml2' 'libxml2' 'libusb' 'libusb-compat' 'remake' 'systemd' 'linux-headers' 'mercurial' 'boost' 'boost-libs' 'libraw1394' 'opencv')
+license=('GPL')
+makedepends=('rpcsvc-proto' 'tree' 'git' 'python-build' 'python-installer' 'python-wheel')
+depends=('python-gitlab' 'python-yaml' 'python-gitpython' 'python-pathlib' 'python-argparse' 'python-pytest')
source=("git+https://gitlab.esss.lu.se/e3/e3.git")
md5sums=('SKIP')
MAKEFLAGS="-j1" # mutithread building breaks this
-prepare() {
- cd e3
- bash e3_building_config.bash -y -t "${srcdir}/build" -b ${pkgver} setup
+pkgver() {
+ cd e3
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd e3
- bash e3.bash base
+ #bash e3.bash base
+ python -m build --wheel --no-isolation
}
package() {
cd e3
- mkdir -p "${pkgdir}/opt/"
- cp -a "${srcdir}/build/base-${pkgver}" "${pkgdir}/opt/ess-epics"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}