summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95da2f4cdc50..591991b4fc36 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Obscurely <adrian.obscurely@protonmail.com>
pkgname=estash-git
-pkgver=0.5.1
+pkgver=v0.5.1.10.g2f8e6bb
pkgrel=1
pkgdesc="An open source, cross-platform, programmed in rust, encrypted digital vault (store files and text) with the capability to set a path and with the click of a button to copy the contents to that file."
arch=('x86_64')
@@ -9,12 +9,12 @@ license=('GPL3')
makedepends=('git' 'rust' 'cargo' 'binutils' 'libx11' 'libxext' 'libxft' 'libxinerama' 'libxcursor' 'libxrender' 'libxfixes' 'pango' 'cairo' 'libgl' 'mesa')
provides=('estash-git')
conflicts=('estash-bin' 'estash')
-source=('git+https://github.com/Obscurely/EStash')
+source=('git+https://github.com/Obscurely/estash')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --long | sed 's/v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long --tags | sed 's/v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {
@@ -40,5 +40,5 @@ package() {
install -Dm755 target/release/estash -t "${pkgdir}/usr/bin/"
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname%-git}/"
- install -Dm644 docs/README.md -t "${pkgdir}/usr/share/doc/${pkgname%-git}/"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname%-git}/"
}