summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 899a2e8663cb..2071a0b6e728 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Andrew Stubbs <andrew.stubbs@gmail.com>
pkgname=etcher
-realver=1.0.0-beta.17
+realver=1.0.0-beta.18
pkgver=${realver//-/_}
pkgrel=1
pkgdesc="Burn images to SD cards & USB drives, safe & easy"
@@ -12,24 +12,31 @@ depends=('gtk2' 'dbus' 'libxi' 'libxcursor' 'libxdamage' 'libxrandr'
'gconf' 'glib2' 'nss' 'xz')
optdepends=('libnotify: for notifications'
'speech-dispatcher: for text-to-speech')
-source=("etcher"
+source=("etcher.in"
"Etcher.desktop"
"etcher.png")
source_i686=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-$realver-linux-x86.zip")
source_x86_64=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-$realver-linux-x64.zip")
options=("!strip")
-md5sums=('8eff5560a3a4cae73698d7eda2d71577'
+md5sums=('45deb94dca8036000f4c03a1634929ee'
'89f5cf77f164510b1f980820aaa4cf91'
'7bd70ef05c6293e36938240be2558091')
-md5sums_i686=('e585bd96708d79845015cc57d86a3f60')
-md5sums_x86_64=('40e2b620d2aecb87e44c8675f2028d03')
+md5sums_i686=('1bafcc0d5d2c8d43bd2ce8948bb51a8b')
+md5sums_x86_64=('35660b65233082a10c00828ea1e50c38')
+
+build() {
+ local a=x86
+ [ "$pkgarch" == "x86_64" ] && a=x64
+
+ sed "s/##AppImage##/Etcher-$realver-linux-$a.AppImage/g" etcher.in > etcher
+}
package() {
local a=x86
[ "$pkgarch" == "x86_64" ] && a=x64
install -D "$srcdir/etcher" "$pkgdir/usr/bin/etcher"
- install -D "Etcher-linux-$a.AppImage" "$pkgdir/usr/share/etcher/Etcher-linux-$a.AppImage"
+ install -D "Etcher-$realver-linux-$a.AppImage" "$pkgdir/usr/share/etcher/Etcher-$realver-linux-$a.AppImage"
install --mode=644 -D "$srcdir/etcher.png" "$pkgdir/usr/share/etcher/etcher.png"
install -D "$srcdir/Etcher.desktop" "$pkgdir/usr/share/applications/Etcher.desktop"
}