summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c3c3a9c9663..e3048bd3704a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=ethminer
pkgver=0.19.0
-pkgrel=1
+pkgrel=2
pkgdesc="Ethereum miner with OpenCL and stratum support (built without CUDA)."
arch=('x86_64')
url="https://github.com/ethereum-mining/ethminer"
license=('MIT')
-depends=('mesa' 'pth')
+depends=('mesa' 'npth')
makedepends=('cmake' 'python' 'git' 'opencl-headers')
conflicts=('ethminer-git')
source=("git+${url}.git#tag=v${pkgver}")
@@ -19,9 +19,6 @@ build () {
cd "$pkgname"
git submodule update --init --recursive
- # add missing library for linking
- sed -i 's/CLI11 Boost::system)/CLI11 Boost::system Boost::filesystem)/' ethminer/CMakeLists.txt
-
mkdir -p build && cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DETHASHCUDA=OFF