summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a793bc167cf..8e0cb8517455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=ethminer-cuda
_pkgname=ethminer
pkgver=0.19.0
-pkgrel=4
+pkgrel=5
pkgdesc="Ethereum miner with OpenCL, CUDA and stratum support."
arch=('x86_64')
url="https://github.com/ethereum-mining/ethminer"
@@ -22,7 +22,7 @@ build () {
git submodule update --init --recursive
# fix https://github.com/ethereum-mining/ethminer/issues/2027
- sed -i '/arch=compute_30/d' libethash-cuda/CMakeLists.txt
+ git cherry-pick dae359dff28f376d4ce7ddfbd651dcd34d6dad8f
# fix https://github.com/ethereum-mining/ethminer/issues/2290
git cherry-pick 9ceee532cded1983fe0cf6a5cc3be9b39b409705
@@ -31,10 +31,13 @@ build () {
# fix https://github.com/ethereum-mining/ethminer/pull/2262
git cherry-pick 6f85e225748029ab8888fec090305f2a7405f046
+ # Enable sm_80 and sm_86
+ git cherry-pick 8f48e43f9232655340badc626863e88cbc960b73
+
mkdir -p build && cd build
- export CC=gcc
- export CXX=g++
+ export CC=gcc-10
+ export CXX=g++-10
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DETHASHCUDA=ON
cmake --build .
}