summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5bd8fa6e682f..c340a9d9b5c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,28 @@
_pkgname=evolution-data-server
pkgname=$_pkgname-git
-pkgver=3.31.1.r028.g21449d4f2
+pkgver=3.50.0.r027.g3a06900142
pkgrel=1
pkgdesc="Centralized access to appointments and contacts"
arch=(i686 x86_64)
-depends=(libgdata
- libgweather
+depends=(gtk4
+ libcanberra
+ libgoa
+ libgweather-4
libical
libphonenumber
- libsignon-glib
+ nss
+ webkit2gtk-4.1
+ webkitgtk-6.0
)
-makedepends=(gnome-common
+makedepends=(git
+ gnome-common
gobject-introspection
gperf
gtk-doc
- intltool
vala
)
+options=(debug strip)
install=$_pkgname.install
url="https://wiki.gnome.org/Apps/Evolution"
license=(GPL)
@@ -44,11 +49,12 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIBEXEC_INSTALL_DIR=/usr/lib \
-DSYSCONF_INSTALL_DIR=/etc \
- -DENABLE_GTK_DOC=ON \
+ -DENABLE_GTK_DOC=OFF \
-DENABLE_INTROSPECTION=ON \
-DENABLE_UOA=OFF \
-DENABLE_VALA_BINDINGS=ON \
-DWITH_PHONENUMBER=ON \
+ -DENABLE_WEATHER=ON \
ninja
}