summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 36 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb55630058cd..896618abb311 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,54 @@
# Contributor: twa022 <twa022 at gmail dot com>
pkgname=ewebkit
-pkgver=1.11.0
-pkgrel=2
+pkgver=1.18
+pkgrel=1
pkgdesc="WebKit ported to the Enlightenment Foundation Libraries"
arch=('i686' 'x86_64')
-url="http://trac.webkit.org/wiki/EFLWebKit"
-license=('LGPL2' 'LGPL2.1' 'BSD')
-depends=('atk' 'cairo' 'efl' 'enchant' 'harfbuzz-icu' 'libsoup' 'libxslt')
-makedepends=('cmake' 'perl' 'python2' 'ruby' 'gperf')
-source=("http://download.enlightenment.org/rel/libs/webkit-efl/$pkgname-$pkgver.tar.xz")
-sha256sums=('d8d21e27f4a21cd77c41914548c184ddb98693ba23851aa66c8e51c0be4b90b7')
+url="http://ewebkit.org/"
+license=('custom')
+depends=('atk' 'efl' 'enchant' 'harfbuzz-icu' 'hyphen' 'libsoup' 'libxslt')
+makedepends=('cmake' 'gperf' 'python' 'ruby')
+source=("https://download.enlightenment.org/rel/libs/webkit-efl/$pkgname-$pkgver.tar.xz"
+ "fix-missing-header.patch")
+sha256sums=('02088758f67fb8e7031bd16e6d871bb4225e62e6de37a2ab408346ab0c45fd72'
+ '7507216f5a21325602bbb950247f99fb2755a02ceb4bca0ab3a8ebb24403793a')
prepare() {
-# Turn off -Werror, causes too many build failures for things we don't care about
- sed -i '/-Werror/d' $pkgname/Source/cmake/WebKitHelpers.cmake
+ mkdir build
+ cd $pkgname
+
+ # Fix missing header
+ patch -Np1 -i ../fix-missing-header.patch
-# Build with glib 2.43+
- sed -i '/^\s\?\+GMutexLocker/ s/GMutexLocker/WebCore::GMutexLocker/' \
- $pkgname/Source/WebCore/platform/graphics/gstreamer/{WebKitWebSourceGStreamer.cpp,MediaPlayerPrivateGStreamerBase.cpp,VideoSinkGStreamer.cpp}
+ # Turn off -Werror, causes too many build failures for things we don't care about
+ sed -i '/-Werror/d' Source/cmake/WebKitHelpers.cmake
}
build() {
- cd $pkgname
-
- cmake . \
+ cd build
+ export LDFLAGS="$LDFLAGS -lpthread"
+ cmake ../$pkgname \
+ -DPORT=Efl \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_TOOLS=OFF
-
- make
+ -DLIB_INSTALL_DIR=/usr/lib \
+ -DLIBEXEC_INSTALL_DIR=/usr/lib/$pkgname \
+ -DENABLE_GEOLOCATION=OFF \
+ -DENABLE_SPEECH_SYNTHESIS=OFF
+ make -j8
}
package() {
- cd $pkgname
-
+ cd build
make DESTDIR="$pkgdir" install
-# install license files
- install -d "$pkgdir/usr/share/licenses/$pkgname/"
- install -m644 Source/WebCore/LICENSE-{APPLE,LGPL-2} "$pkgdir/usr/share/licenses/$pkgname/"
+ install -m755 -d "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$srcdir/$pkgname/Source"
+ for f in $(find -name 'COPYING*' -or -name 'LICENSE*'); do
+ echo $f >> "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cat $f >> "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ echo "" >> "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ done
}