summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82929f1f5fbd..89a96a85c20b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,42 +7,43 @@
# Contributor: Joshua Stiefer <facedelajunk@gmail.com>
pkgname=exaile
-pkgver=4.1.2
+pkgver=4.1.3
pkgrel=1
pkgdesc="A full-featured Amarok-style media player for GTK+"
arch=('any')
url="https://www.exaile.org/"
license=('GPL2')
-depends=('python>=3.6'
+depends=('python>=3.8'
'python-bsddb'
- 'gtk3>=3.22.0'
- 'gst-python>=1.14.0'
- 'gst-plugins-base>=1.14.0'
- 'gst-plugins-good>=1.14.0'
- 'python-mutagen>=1.38.0'
+ 'gtk3>=3.24.0'
+ 'gst-python>=1.16.0'
+ 'gst-plugins-base>=1.16.0'
+ 'gst-plugins-good>=1.16.0'
+ 'python-mutagen>=1.44.0'
'python-dbus'
'python-cairo'
- 'python-gobject')
-makedepends=('pygobject-devel>=3.22.0' 'help2man')
+ 'python-gobject>=3.24.0')
+makedepends=('pygobject-devel>=3.24.0' 'help2man')
checkdepends=('python-pytest')
optdepends=('udisks2: device detection'
- #'python-discid: CD info'
+ 'python-discid: CD info'
+ 'python-musicbrainzngs: CD info / Musicbrainz covers'
'spydaap: DAAP server'
'python-zeroconf: DAAP plugins (daapserver and daapclient)'
- 'ipython: ipconsole plugin'
'python-pylast: Last.FM integration'
'python-lxml: lyrics from lyricsmania.com (lyricsmania)'
- 'python-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)'
- 'python-musicbrainzngs: Musicbrainz covers'
'python-feedparser: podcast plugin'
'webkit2gtk: Wikipedia info'
'libkeybinder3: Xlib-based hotkeys'
'librsvg: scalable icons'
- 'libnotify: recording streams'
+ 'libnotify: native notifications'
+ 'streamripper: recording streams'
'moodbar: moodbar plugin'
- 'gst-plugins-bad: BPM Counter plugin')
+ 'gst-plugins-bad: BPM Counter plugin'
+ 'python-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)'
+ 'ipython: ipconsole plugin')
source=("$pkgname-$pkgver.tar.gz::https://github.com/exaile/exaile/archive/$pkgver.tar.gz")
-sha512sums=('7711f9e062088b02362bbd404f7c61a0f1c128e29e42ce657dc092cac351641f6000846c9da843866bf28ccbd68cf1b07731ba1c9854d52b33c0448e87d0e93b')
+sha512sums=('16b31331a31f0a2e088f177c8a01ef47603b07fe94cbb19869a4caeaec2da03cacaa07d5b0eb50052645449e07620e2c58f202007108af73e20cf744d70bb556')
build() {
cd "$srcdir/$pkgname-$pkgver"